horn troubles

Wiring, power windows, power seats, radios, heaters, fans, motors, relays, air conditioning, autronic eye, and other accessories or wiring-related items.

horn troubles

Postby dvonk » Tue Aug 03, 2010 3:54 pm

i have had the worst luck with horns. first of all, my '58 Special only came with one horn. so, the quest began to find another mate for it--it only took me like 3 years to finally get a working one. i installed it a couple of months ago, thinking that was that. well, i was wrong. today i tried out the horns, and now neither of them work. :x i tried testing them each individually, and both made a *clunk* noise when a current was applied. in my quest to obtain a functional mate, ive taken one apart that exhibited the same symptoms, so i know how they work and what they look like inside.

my question is this: do you think the parts inside have rusted? its always ridiculously humid in Omaha, and i dont have the luxury of a climate-controlled garage. however, the car was stored outside for 3+ years before we purchased a house with a garage, and i never had any horn problems. im just kinda wondering if im overlooking something, or looking for a easy 'oh, duh' type fix.

if possible, id like to avoid taking them apart, since taking apart the horns involves drilling out all the rivets that hold the two halves together--these are obviously not supposed to be a serviceable part. unfortunately, they are somewhat scarce 52 years later.

anyone have any experience with the horns? also, if anyone wants photos of the guts of the horn, i can take some.
1958 MOD. 43
STYLE 58-4439
BODY No. BK2451
TRIM 412
PAINT CG
ACC. E (also BFG)
User avatar
dvonk
'58 Buick Addict
 
Posts: 177
Joined: Sat Apr 12, 2008 5:53 pm
Location: Omaha, NE

Return to Electrical and Accessories

Who is online

Users browsing this forum: No registered users and 1 guest